STS(Eclipse)にLombokの設定がやっとできたので備忘録

spring boot

STS(Eclipse)にLombokをいれるのに苦労しました。
もしかして私のように苦労している人のお役に立てられたらと思い書き残しておきます。

いろいろなサイトを参考にして試してみたのですが、どれもうまく行かずやっているうちにうまくインストールできました笑

ではいってみよう!

まずはこちらに移動して下記をクリックしてダウンロードします。

そしてダウンロードしたものをダブりクリックします。

すると下記のように起動します。

どうもSTS(Eclipse)が見つからないみたいですね。
他のサイトをみてると勝手に見つけてけてくれるらしいですが、何度繰り返しても私の場合は見つけてくれませんでした。

仕方ないので手動で探すしかありません。まずは上記の「OK」ボタンを押します。
下記の矢印の部分をクリックします。

Finderが開くので「Applications」を選択肢「Spring ToolSuite4」をクリックします。

そして下記の画像を参考にしてもらえばわかるとおもいますが、
「Contents」→「Eclipse」→「Spring ToolSuite4.ini」をそれぞれクリックしていきます。

最後に「Open」をクリックします。

そしたら下記の画像のように表示されるのを確認して、矢印の「Install/Update」をクリックします。

下記のように「Install successful」の表示に切り替わるので、矢印の「Quit Installer」をクリックして完了です。

私の場合は上記の方法でうまくLombokをインストールできました。
誰かのお役に立てられたら幸いです。

コメント

タイトルとURLをコピーしました